这些指导信息适用于 Linux 上的 4.4.2 版本的 ApplixWare.请参考 Linux 系统管理 在线手册获取更详细的信息.
以 root 身份编辑文件 applixroot/applix/axdata/axnet.cnf.
#libFor elfodbc /ax/...把这一行改成
libFor elfodbc applixroot/applix/axdata/axshlib/lib告诉 elfodbc 在这个路径里查找 ODBC 支持库.通常 Applix 被装在 /opt,这样完整的路径就是 /opt/applix/axdata/axshlib/lib,但如果你在其他地方安装了 Applix ,相应的修改路径.
TextAsLongVarchar=0到 .odbc.ini 的数据库声明部分,这样文本字段就不会显示为 **BLOB**。
选择感兴趣的 Postgres 数据库.
选择 ODBC,并且敲击 Browse.你在 .odbc.ini 里配置的数据库应该显示出来.确保 Host: field 是空的(如果不是,axnet 将试图与另一台机器的 axnet 联接查找数据库).S
选择敲击 Browse 显示出的数据库,然后敲击 OK.
在登录标识对话框里输入 username(用户名)和 password (口令).然后敲击 OK.
'Ready'(就绪)信息将在数据窗口的左下角出现.这表明你现在可以输入查询.
从 Query->Choose tables 选择一个表,然后选择 Query->Query 来访问该数据库.表的头 50 行左右的信息将显示出来.
- 九月发布的 ApplixWare v4.4.1(第一个有 Linux 下官方支持的 ODBC)在用户名超过八(8)字符长时有问题.这个问题是 Steve Campbell 发现的.
作者:由 Steve Campbell 在 1998-10-20 提交.
在 axnet 进程上运行一个 strace.例如,如果
% ps -aucx | grep ax显示
cary 10432 0.0 2.6 1740 392 ? S Oct 9 0:00 axnet cary 27883 0.9 31.0 12692 4596 ? S 10:24 0:04 axmain那么运行
% strace -f -s 1024 -p 10432检查 strace 输出.
来自 Cary :许多从 ApplixWare 来的错误信息输出到 stderr,但是我不能确定 stderr 发送到哪里,所以 strace 是把它们找出来的方法.
[pid 27947] open("/usr/lib/libodbc.so", O_RDONLY) = -1 ENOENT
(No such file or directory)
[pid 27947] open("/lib/libodbc.so", O_RDONLY) = -1 ENOENT
(No such file or directory)
[pid 27947] write(2, "/usr2/applix/axdata/elfodbc:
can't load library 'libodbc.so'\n", 61) = -1 EIO (I/O error)
所以发生的错误是 applix elfodbc 在查找 libodbc.so,但是找不到.这就是为什么
axnet.cnf 需要修改的原因.编辑本地 sqldemo.am 的拷贝:
修改这些成为 null_clause = ""
从 Macro Editor 里打开 sqldemo.am 文件.
选择 File->Compile and Save.
退出 Macro Editor.
运行 Applix Data.
选择 *->Run Macro
输入值 “sqldemo”,然后敲击 OK.
你应该看到数据窗口状态栏的的进度(在左下角).
你现在应该可以访问 demo 表.